Squarespace connection issues
Incident Report for Printful
Resolved
Connection issue with Squarespace Integration has been fixed, and normal operations are resuming
Posted Jul 03, 2024 - 11:49 UTC
Investigating
There are connection issues with Squarespace, and some stores fail to sync. We're investigating the cause, and we'll keep you posted.
Posted Jul 03, 2024 - 09:06 UTC
This incident affected: Integrations (Squarespace).